Creating Talk:System requirements

Jump to: navigation, search

Warning: You are recreating a page that was previously deleted.

You should consider whether it is appropriate to continue editing this page. The deletion and move log for this page are provided here for convenience:

  • 13:37, 5 April 2021 Titi4600 talk contribs deleted page Talk:System requirements (content was: "===System requirements should be updated=== Title. System requirements are misleading and definitely do not belong here in their current state. Considering a lot of new players visit the wiki, they need to be updated. User:Goder5555|Go...")
  • 22:21, 3 October 2020 Muhawi talk contribs deleted page Talk:System requirements (content was: "Source of this page : [https://www.escapefromtarkov.com/support/knowledge/68 BSG system requirements] Titi4600 ([...", and the only contributor was "Titi4600" (talk))
This is a talk page. Please remember to sign your posts using four tildes (~~~~).

Warning: You are not logged in. Your IP address will be publicly visible if you make any edits. If you log in or create an account, your edits will be attributed to your username, along with other benefits.

Please note that all contributions to Escape from Tarkov Wiki are considered to be released under the CC BY-NC-SA 3.0 (see Escape from Tarkov Wiki:Copyrights for details). If you do not want your writing to be edited mercilessly and redistributed at will, then do not submit it here.
You are also promising us that you wrote this yourself, or copied it from a public domain or similar free resource. Do not submit copyrighted work without permission!

Cancel Editing help (opens in new window)